Skip to content

StarTeam install woes

24 February 2009

I spent two hours trying to figure out why StarTeam 2008 Release 2 Client wouldn’t install correctly on my machine. Whenever I’d launch it, I’d get a “Could not create the Java virtual machine” error.

Rather than being a problem locating the Java Virtual Machine, as I’d previously thought, turns out it’s a memory allocation issue. In StarTeamCP.stjava, the default option set is “-Xmx1024m”. My machine doesn’t have a gig of RAM to spare for a Java VM, hence the error. By setting it to “-Xmx512m”, I was able to get up and running.

I’m posting this in the hopes someone can profit from my struggles this morning. Deep shame be unto Borland for:

1) Making the default 1 GB, which is unrealistic for quite a few machines, mine included
2) Not putting it in their Platform Notes with the release documentation.

Advertisements
27 Comments leave one →
  1. Laurie permalink
    18 March 2009 7:49 am

    Worked like a charm. Thanks!

  2. New Light permalink
    16 June 2009 7:29 am

    Yes… worked for me. spent two hours before coming across your webpage.

    Thanks.

  3. quangtin3 permalink
    23 June 2009 1:58 am

    Thanks neontapir for sharing this with us. How did you find out with just a general error message?

    • neontapir permalink
      30 June 2009 12:04 am

      I watched StarTeam launch with Task Manager. As Tess Ferrandez points out in a post on .NET memory usage, Virtual Memory Size can be a more useful counter than the normal one.

      It showed that StarTeam was using up hundreds of megabytes before I got the message. I asked myself why it was taking so much memory, so I did some internet research on Java virtual machine memory allocation, which led me to discover what I shared in the post.

      Thanks for stopping by!

  4. cuongdm permalink
    25 June 2009 3:03 am

    Thank, I’ve lost so much time, before read your webpage

  5. Janel permalink
    26 June 2009 2:46 am

    Works for me too! Thank you so much for sharing!

  6. Shiva permalink
    13 July 2009 12:36 am

    Many Thanks. works for me.

  7. Venkat Voleti permalink
    22 July 2009 11:26 pm

    neontapir,Many thanks. It works for me.

  8. minhbt permalink
    27 July 2009 12:45 am

    Thank you! It really works

  9. SonPN_V&E permalink
    5 August 2009 8:23 pm

    Thank you so much for sharing.

  10. SonPN_V&E permalink
    5 August 2009 8:25 pm

    Thank you for sharing with us

  11. Sree permalink
    5 October 2009 2:42 pm

    Thank you very much for sharing this information. I did spend almost installing and installing Java virtual machine and starteam

  12. 13 November 2009 1:08 am

    Wonderful, thanks for sharing the knowledge and shame on Borland for not sharing it!

  13. 18 February 2010 3:02 pm

    Worked fine for me..
    Thanks a lot!

  14. suman permalink
    5 March 2010 2:32 pm

    It does not work for me. Is there any other suggestions !!!!!

    Thanks,
    Suman

  15. Srinivasan permalink
    3 May 2010 3:04 pm

    Dear Finder,

    It worked really. Thanks a lot. I appriciate your efforts and also thought of sharing with others.

    I prey for you/likely minded people to live longer years…!!

    Warm Regards,
    Srini

  16. GIGABYTE permalink
    3 May 2010 3:08 pm

    Awesome.. It worked in a jiffy!!

  17. FrustratedUser permalink
    24 June 2010 5:01 pm

    Thank you very much, very annoying that this is not mentioned in the borland doco, well done

  18. 9 July 2010 8:30 am

    You really helped us out of a jam! Thank you very much for this post!

  19. CAQ permalink
    17 August 2010 5:23 am

    Thank you! This worked like a charm (after 6 hours of trying to find the issue) – as you said – Shame on Borland!

  20. helen permalink
    25 September 2010 10:52 am

    Genius!!! Worked like a dream – thank you so much for posting this solution.

    • neontapir permalink
      25 September 2010 11:17 am

      I’m so glad it worked for you!

  21. Leo Nobrega permalink
    29 October 2010 10:32 am

    Yeah! It worked for me two… I tryed everything and I spent a lot of hours trying to solve that. I reinstalled this SW thousand of times, I tryed to change some entries in the registry… but the solution was so simple that makes me feel embarissing! Thank you for sharing this with us.

    • Priya permalink
      15 March 2011 5:02 am

      Excellent!!! Worked Great! Thanks a ton.

  22. Sethu permalink
    18 October 2011 12:17 am

    You are a genius!!This Worked out.

  23. Aditi permalink
    25 April 2012 11:52 am

    you are AWESOME! Thanks a ton !

  24. Rahul permalink
    17 May 2012 8:51 am

    Thanks a lot Brother … you are genius šŸ™‚

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: